DomainKey And DKIM Working Simultaneously In Kloxo

I have DomainKey and DKIM working simultaneously.

Here’s what you need to do

1. Install Mail::DKIM perl module

yum install perl-Mail-DKIM

2. Install libdomainkeys

rpmbuild --rebuild  libdomainkeys-toaster-0.68-1.3.6.src.rpm
rpm -ivh /usr/src/redhat/RPMS/i386/libdomainkeys-toaster-0.68-1.3.6.i386.rpm

3. Download and copy it to /usr/bin
4. Download

mv /var/qmail/bin/qmail-remote /var/qmail/bin/qmail-remote.orig
cp /var/qmail/bin/qmail-remote
chmod 755 /var/qmail/bin/qmail-remote
rm /var/qmail/bin/qmail-queue
mv /var/qmail/bin/qmail-queue.orig /var/qmail/bin/qmail-queue

6. Edit /var/qmail/bin/qmail-remote. goto line 49 and replace

error=`( --type=dkim --selector=default \


error=`( --type=dkim --selector=dkim \

7. Finally do not forget to add DKIM DNS TXT record.     IN  TXT  "v=DKIM1; g=*; k=rsa; p=MEwwDQYJKoZIhvcN.....AQAB"

the “p=MEwwDQYJKoZIhvcN…..AQAB” part is same as that for your domainkey created by kloxo

You can do a test by sending mail to yahoo or gmail

This basically works on most qmail toaster installation.

Hope this helps everyone here

  • Vijay


    Thank you for your wonderful guide. I have implemented the same, the website is down in the 2nd step (wget, i downloaded it from another source. How much time does it take to update as i still don’t see DKIM or Domainkeys in the email.


  • There maybe some problem with the config then , as the settings takes effect instantly .

  • Lil


    Thanks for the good guide! I have a problem, I get the mails returned saying “Unable to run qmail remote” Can you advise where can I look for the problem? Thanks

    • Hi,

      Thanks for writing back, please try /script/restart via terminal/SSH and check if the problem resolves.

      Stacy C.